Please always enter the name of the template and the Joomla version and the live URL if available

TP_BRAND & PHP 8.2

TP_BRAND & PHP 8.1 was created by infra.assuralia

Posted 1 year 2 months ago #32855
Hi there,
Is it possible that (some) templates are not PHP 8.1 compatible yet?
Because when I update my PHP, I get a lot of errors on TP_BRAND template:

  1. Deprecated: strtotime(): Passing null to parameter #1 ($datetime) of type string is deprecated in .. templates/tp_brand/html/com_content/featured/default_item.php on line 28

  2. Deprecated: Use of "self" in callables is deprecated /www/libraries/astroid/framework/library/astroid/Helper/Form.php on line 51
  3. Warning: Cannot modify header information - headers already sent by (output started at /www/libraries/astroid/framework/library/astroid/Template.php:105) in /www/libraries/astroid/framework/library/astroid/Helper/Client.php on line 87
  4. Deprecated: Creation of dynamic property Astroid\Template::$version is deprecated in /www/libraries/astroid/framework/library/astroid/Template.php on line 105
....
Last Edit:1 year 2 months ago by infra.assuralia
Last edit: 1 year 2 months ago by infra.assuralia.

Please Log in or Create an account to join the conversation.

Replied by WM-Loose on topic TP_BRAND & PHP 8.2

Posted 1 year 2 months ago #32856
Astroid 2.6.4 is ready for php8.2.
Look to your version and install 2.6.4.
Kind regards,
Dirk
Joomlaplates Admin
Joomla-Master in forum.joomla.de/

Please Log in or Create an account to join the conversation.

Replied by infra.assuralia on topic TP_BRAND & PHP 8.2

Posted 1 year 2 months ago #32857
Astroid 2.6.4. is installed

Please Log in or Create an account to join the conversation.

Replied by WM-Loose on topic TP_BRAND & PHP 8.2

Posted 1 year 2 months ago #32858
I would just wait and see. Many extensions and plugins do not yet run under php8.2 and need to be adjusted. As long as everything works with php8.1 there is no reason to go to 8.2.
Kind regards,
Dirk
Joomlaplates Admin
Joomla-Master in forum.joomla.de/

Please Log in or Create an account to join the conversation.

Replied by joomlaplates on topic TP_BRAND & PHP 8.2

Posted 1 year 2 months ago #32859
Hello,
Astroid and the Templates are running well with PHP 8.2.
Your messages are just for information and no errors
> Deprecated and Warnings are messages for information

Please Log in or Create an account to join the conversation.

Moderators: joomlaplates

Installations-Service

Don´t waste your time, we install your purchased Template
with the "Demo Content" within the next 24 hours.

Buy Now - 59€

Joomlaplates/Theme-Point is not affiliated with or endorsed by Open Source Matters or the Joomla! Project

Copyright © 2022 JoomlaPlates | Professional Joomla Templates with Uikit 3

Disclaimer & Privacy | License